PSP N2O

USD $149.00 (UK/EU orders incur VAT)

PSP N2O is a semi-modular multi-effect plug-in which offers unparalleled flexibility and total sound creation freedom. The high-quality sound processing modules can be routed in any configuration, allowing for endless musical journeys.

SKU: 1246-1194 Categories: , ,

Description

Summary

While built upon the same basic concept as PSP Nitro, PSP N2O, with its new modules and extended modulation features, explores completely new sonic areas. The plug-in engine has been re-written and re-designed from scratch in order to improve the sound and take full advantage of the optimizations offered by modern CPUs. The enhanced user interface improves the experience of both sound designers creating their own soundscapes as well as everyday users who aren’t as fond of looking under the hood.

Key Features

  • up to four sound processing operators at a time; among the available types are: morphing resonant and formant filters, eq, delay, reverb, pitch-shifter, compressor/expander, bitcrusher, distortion, full-wave rectifier and many more
  • up to four modulators at a time; the list includes: LFO, envelope detector, ADSR step sequencer
  • eight assignable knobs with quick MIDI learn option for convenient access to the most essential preset parameters
  • built-in limiter that uses algorithms from our extremely well regarded PSP Xenon hi-definition mastering limiter
  • three displays, simplified modulation setup, keyboard and mouse wheel support for easy preset creation and tweaking
  • animated response plots
  • sidechain (key) input
  • extensive SSE optimization
  • 192 factory presets
  • expandable architecture – new operators and modulator types to be added in future versions while preserving backward compatibility

System Requirements

The PSP N2O is available in the non iLok version only.

MAC Minimum Requirements

  • AudioUnit: Mac OSX 10.5 or later, 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view
  • VST: Mac OSX 10.5 or later, 32 or 64-bit VST 2.4 compatible host application
  • RTAS: Mac OSX 10.5 or later, ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

PC Minimum Requirements

  • VST: Windows x32 or x64 (XP Service Pack 2, Vista or 7), VST 2.4 compatible application
  • RTAS: Windows x32 or x64 (XP Service Pack 2, Vista or 7), ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

No refunds are possible on digital products – view our full Refund Policy here.

Select your currency
USD United States (US) dollar